Die Menüleiste

Die Menüleiste des Grafikeditors GEDI stellt folgende Menüs bereit, die in diesem Kapitel samt Bedienung erklärt.

Als Eingabehilfen im GEDI gibt es neben den Menüs und den Symbolleisten (Die Symbolleisten), die Tastaturbedienung.

Tastaturbedienung

Der jeweilige Tastenbefehl wird neben dem Menüeintrag angezeigt. Ein neues Panel erstellen Sie z.B. mit CTRL+ N. Innerhalb der Menüs navigieren Sie mit den Cursortasten.

Das Menü Modul

Über das Menü Modul:

  • Öffnen Sie ein neues GEDI (Grafikeditor)-Fenster.
  • Öffnen Sie ein Panel im Modul VISION.
  • Öffnen Sie das PARA-Modul. Siehe Grundlagen Modul PARA.
  • Öffnen Sie das System Management-Panel. Siehe System Management.
  • Öffnen Sie die Paneltopologie. Siehe Grundlagen Paneltopologie/Summenmeldung.
  • Schließen Sie das Fenster. D.h. Wenn mehrere Module offen sind, wird nur dieses Fenster geschlossen.
  • Schließen Sie die Benutzeroberfläche (Exit)

Abbildung: Das Menü "Modul"

Das Menü Panel

Das Menü Panel ermöglicht das Erstellen (Neues Panel), Öffnen (Panel Öffnen), Schließen (Panel Schließen), Drucken (Drucken) und Speichern (Panel Speichern, Panel Speichern unter... oder Panel Speichern als Version) von Panels (siehe Panels speichern). Es werden auch die zuletzt geöffneten Panels angezeigt. Durch einen Klick auf einen Dateinamen können Sie die Datei wieder öffnen. Das Panel kann auch im QuickView-Modus (Speichern und im Quicktest Modul öffnen) geöffnet werden.

ACHTUNG:

Beachten Sie, dass überparametrierte Objektreferenzen zueinander verschoben werden, wenn im Quicktest mit der Lupe ein neuer Zoomfaktor eingestellt wird!

Abbildung: Das Menü Panel

So öffnen Sie ein existierendes Panel

  1. Selektieren Sie im Menü Panel den Eintrag PanelÖffnen. Das Fenster für den Dateiauswahldialog wird geöffnet.
  2. Wählen Sie eine Datei aus und drücken Sie die Enter-Taste (oder die Öffnen-Schaltfläche).

Abbildung: Dateiauswahldialog Wähle eine Datei

Der Dialog Wähle eine Datei zeigt standardmäßig das Verzeichnis /panels des aktuellen Projektverzeichnisses. Sie können weitere Unterverzeichnisse anlegen und öffnen. In der obigen Abbildung sehen Sie das Verzeichnis /panels des Projektes.

Das Panel oder Bild wird in dem Datei-Selektor angezeigt. Beachten Sie dabei, dass unsichtbare Objekte der Panels nicht angezeigt werden. Beachten Sie auch, dass im Panels-Verzeichnis nur Panels und im Pictures-Verzeichnis nur Bilder angezeigt werden können.

Panels speichern

Das Panel wird als Datei mit der Dateierweiterung ".pnl" im aktuellen Projektverzeichnis im Unterverzeichnis /panels gespeichert. Falls sich ein Panel mit dem gleichen Namen bereits im Projektverzeichnis befindet, so erscheint eine Dialog, mit dem das Panel überschrieben werden kann (Ja - Überschreibt das Panel, Nein - Dialog "Speichern unter" wird geöffnet, Abbrechen - Bewirkt keine Aktion).

So speichern Sie ein Panel

  1. Selektieren Sie im Menü Panel den Eintrag Panel speichern (save panel) oder diese Schaltfläche .

Beim erstmaligen Speichern eines Panels erscheint der Dateiauswahldialog Speichern unter:

  1. Geben Sie im Dateiauswahldialogfenster einen neuen Dateinamen ein.
  2. Drücken Sie die Enter-Taste oder klicken Sie auf Speichern.

Panels aus Subprojekten

Beim Speichern eines Panels aus einem Subprojekt erscheint zunächst der Speicherdialog des Panels. Nach Auswahl der "Speichern"-Option öffnet sich ein Dialogfenster zur Auswahl, an welcher Stelle das Panel gespeichert wird. Das Panel kann entweder zurück in das Subprojekt oder in das aktuelle Projekt gespeichert werden. Es kann an dieser Stelle auch der Speichervorgang mit "Abbrechen" ganz abgebrochen werden.

Um das Speichern mehrerer Änderungen in einem Subprojekt zu erleichtern, kann das Subprojekt selbst entsperrt werden. Geänderte Panels aus diesem Subprojekt werden dann immer dort gespeichert. Ein Subprojekt wird in der Projekt Ansicht mit einem Rechtsklick entsperrt und zeigt dann ein "offenes Paket" Symbol.

Dieses Verhalten kann mit dem Config-Eintrag [ui] subprojectsWritable aktiviert und deaktiviert werden.

ACHTUNG:

Die Operationen in einem Subprojekt sind auf das Speichern beschränkt. Andere Dateioperationen (z.B.: Datei umbenennen oder löschen) können nicht verwendet werden.

Das Entsperren ist auf Subprojekte beschränkt, und inkludiert nicht die Installation selbst.

Zusätzlich zu Panels, können auch Message Kataloge, Libraries und Skripte in Subprojekten gespeichert werden.

So ändern Sie Paneldateinamen

Beim erstmaligen Speichern oder zur Änderung von Dateinamen und zur Erstellung zusätzlicher Unterverzeichnisse rufen Sie den Dateiauswahldialog für Speichern auf, indem Sie im Menü

Panel -> Speichern unter... selektieren.

Abbildung: Dateiauswahldialog für Speichern einer Datei

Mit Panel Speichern als Version können Sie das Panels in einer älteren WinCC OA Version speichern.

Im GEDI einer älteren WinCC OA Version kann das Panel ohne Einschränkungen geöffnet werden. Beachten Sie jedoch, dass einige aktuelle Panel Features in einer älteren WinCC OA Version nicht unterstützt werden (z.B. Transparenz). Diese werden automatisch an die Möglichkeiten der älteren WinCC OA Version angepasst.

Referenzen speichern

Der Grafikeditor GEDI von WinCC OA bietet die Möglichkeit, Referenzobjekte zu erstellen und diese als Referenzpanels in anderen Panels weiterzuverwenden. Die so eingebundenen Bestandteile übernehmen im weiteren jede Eigenschaftsänderung, die im Referenzobjekt vorgenommen wurde. Auf diese Weise können beispielsweise übergreifende Ersetzungen in allen Anlagenbildern vorgenommen werden, in dem einfach das originale Referenzpanel geändert wird.

Referenzpaneldateien werden mit der Dateierweiterung.pnlim Unterverzeichnis.../panels/objectsgespeichert.

Erstellen Sie ein Referenzpanel

  1. Öffnen Sie ein neues Panel und zeichnen Sie ein Grafikobjekt, das z.B. ein rotes Licht darstellt. Beispielsweise eine rote Kreisfläche und rote Linien als Strahlen.
  2. Klicken Sie im Menü Panel auf Speichern Unter. Im Dateiauswahldialog wählen Sie das Unterverzeichnis objects und vergeben Sie einen Namen für dieses Referenzpanel, beispielsweise ,,RotesLicht". Klicken Sie auf die Schaltfläche Speichern.

Panel im Laufzeitbetrieb ansehen (Quicktest Panel)

Mit Quicktest Panel wird das aktuell geladene Panel gespeichert und im Modul VISION aufgeschaltet.

Das Menü Editieren

Dieses Menü stellt allgemein bekannte Bearbeitungsfunktionen (Cut, Copy und Paste) zur Verfügung. Format Übertragen überträgt die Attribute eines Grafikobjekts auf ein anderes. Es können auch neue CTRL-Scripts und CTRL-Libraries (Bibliotheken) erstellt werden. Projekt Ansicht Aktualisieren aktualisiert die Projektansicht. Reload Stylesheet aktualisiert die Ansicht anhand der verwendeten CSS-Datei. CTRL Libraries neu laden aktualisiert die CTRL-Libraries (Bibliotheken). Shape/Gruppe Auswählen...öffnet dasSelect Shape/Shape Group/Panel Ref-Fenster, indem Sie ein Objekt oder eine Objektgruppe selektieren können (siehe die zweite Abbildung unterhalb). Mittels der Schaltfläche Panel Öffnen können Sie das innerhalb des Auswahlmenüs gewählte (Referenz-)Panel direkt öffnen. Verwenden Sie dieses Panel speziell, wenn Sie ein Objekt innerhalb einer Referenz selektieren wollen (Siehe auch Kapitel Eigenschaften von Referenzen und Überparametrierung). Kurzbefehle... öffnet ein Panel (Aktionen editieren) indem Sie Tastenkombinationen (shortcuts) für die Funktionen vom Grafikeditor definieren können (Siehe die dritte Abbildung unterhalb).

Abbildung: Menü Editieren

Abbildung: Kurzbefehle... - Aktionen editieren

So kopieren Sie ein Grafikobjekt

  1. Markieren Sie ein oder mehrere Grafikobjekte.
  2. Selektieren Sie im Menü Bearbeiten (Edit) die Funktion Kopieren (Copy). Die ausgewählten Objekte werden in den Zwischenspeicher kopiert.
  3. Selektieren Sie Einfügen (Paste). Die ausgewählten Objekte werden im ausgewählten Panelfenster, ein Stück nach rechts unten versetzt, eingefügt.

Das Menü Ansicht

Abbildung: Menü Ansicht

Attribut Editor

Öffnet das Eigenschaftenfenster. Siehe Kapitel Das Eigenschaftenfenster.

Projekt Ansicht

Öffnet die Projektansicht. SieheProjekt-Ansicht.

Shape/Gruppenselektor

Öffnet das Panel zum Auswählen der Objekte bzw. Objektgruppen, in dem angezeigt wird, von welchem Typ ein Objekt ist oder in welcher Reihenfolge sie eingefügt wurden.

Abbildung: Shape/Gruppenselektor

DP Baum Ansicht

Öffnet den Datenpunktbaum. SieheModul PARA.

Panel Übersicht

Öffnet einen Liste aller offenen Panels inklusive einer grafischen Vorschau. Zu den geöffneten Panels werden folgende Informationen angezeigt:
  • Panelname (bzw. Dateiname wenn kein Panelname angegeben ist) mit Panelformat (XML oder PNL)
  • Pfad inklusive Dateiname
  • Projektname (von Subprojekt oder Installation, beim eigenen Projekt bleibt dieses Feld leer).

Suchfenster

Öffnet ein Suchfenster in dem Sie nach bestimmten Inhalten suchen können. Das Suchfenster hilft Ihnen bei der Suche nach Inhalten oder Mustern in Dateien (Panels, Scripte, Libraries, Text Katalogen, Config-Dateien, Datenpunkt-Listen und Data-Verzeichnissen) in Ihrem gesamten WinCC OA Verzeichnis oder nur im Projektordner.

Abbildung: Das Suchfenster

So suchen Sie im Suchfenster

  1. Wählen Sie in der rechten Combobox den Dateityp, der durchsucht werden soll.
  2. Haken Sie die Checkbox "Muster" an, wenn nach einem Muster gesucht werden soll. Der Input wird als Perl kompatibler regulärer Ausdruck zur Suche verwendet, siehe dazu Qt QRegularExpression Class und regexpIndex().
  3. Haken Sie die Checkbox "" an, wenn jede Datei mit entsprechendem Inhalt nur einmal angezeigt werden soll.
  4. Haken Sie die Checkbox "Alle" an, wenn die WinCC OA-Verzeichnisse außerhalb Ihres Projektordners auch durchsucht werden sollen.
  5. Geben Sie im linken Eingabefeld den Suchbegriff ein und bestätigen Sie mit der Schaltfläche .
  6. Im Ausgabefenster werden alle Treffer mit den Verzeichnispfaden gelistet, in welchen Ihr Suchbegriff vorkommt.
  7. Der Fortschrittsbalken unten zeigt Ihnen an, ob die Suche abgeschlossen wurde (= 100%).
  8. Zusätzlich werden Sie über die Anzahl der Treffer informiert.
  9. Um eine Suche vorzeitig abzubrechen, klicken Sie auf die Schaltfläche .
  10. Mit einem Doppelklick auf den Dateinamen im Ausgabefenster wird die Datei geöffnet.
Anmerkung:

Beachten Sie, dass Wildcards wie *zoom* nicht verwendet werden dürfen. "zoom" liefert alle Panels/Scripts in denen "zoom" vorkommt.

Die Suche funktioniert ähnlich wie regexpIndex(), verwendet aber die neuere QRegularExpression Class anstelle der QRegExp Class.

Log Fenster

Öffnet den Log Viewer. Schließt man den Log Viewer, der mit der Console gestartet wurde und startet den Log Viewer über den GEDI, ist es möglich per Doppelklick auf eine Fehlermeldung (z.B. bei einer undefinierten Funktion) zur Fehlerquelle zu gelangen. Tritt der Fehler in einem Panel auf, wird durch einen Doppelklick auf die Fehlermeldung das entsprechende Panel im GEDI geöffnet und das fehlerhafte Objekt selektiert. Im Fall einer fehlerhaften Library wird diese geöffnet und die betreffende Code-Zeile ausgewählt.

QuickTest leert Anzeige im Log Viewer

Löscht bei Neustart des QuickTests alle Meldungen aus dem Log Viewer. Diese Funktion funktioniert jedoch nur mit dem vom GEDI aufgerufenen Log Viewer. Für den von der Console aufgerufenen Log Viewer kann diese Funktion nicht verwendet werden.

Katalog für alle Objekte

Öffnet den Katalog mit WinCC OA Standardsymbolen. SieheGrundlagen zu STD_Symbolen.

Kataloge

Selektieren Sie hier entweder den WinCC OA Objektkatalog C:\Siemens\Automation\wincc_oa\[versionoder die eigenen Referenzobjekte aus dem Projektverzeichnis. Siehe auchGrundlagen zu STD_Symbolen.

Zeige unsichtbare Objekte

Zeigt die unsichtbaren Objekte (Eigenschaft "Sichtbar" im Eigenschaftenfenster).

Zeige Panel Hintergrundbild

Zeigt den Panel-Hintergrund-Bild (wenn ein Bild angegeben wurde).

Sichtbare Ebenen

Zeige Ebene 1 bis Zeige Ebene 8 zeigt die verschiedenen Ebenen eines Panels.

Vergrößern

Ermöglicht ein stufenweises Vergrößern/Heranzoomen des Panels.

Verkleinern

Ermöglicht ein stufenweises Verkleinern/Hinauszoomen des Panels.

1:1 Originalgröße

Stellt die Originalgröße des Panels wieder her.

Gitter ein/ausschalten

Blendet die Rasterlinien aus.

Gitterfang ein/ausschalten

Schaltet die Fangpunkte ein und aus.

Objektfang ein/ausschalten

Schaltet die Fangpunkte (Eckpunkte, Mittelpunkte entlang der Linien, Zentrum) bei Objekten ein und aus. Durch Einschalten von Objektfang können beispielsweise Linien genau mit dem Eckpunkt eines Objekts verbunden werden.

Linien Objektfang ein/ausschalten

ZeigtHilfslinien zu den Fangpunkten an den Außengrenzen (oben, unten, links, rechts) sowie dem Mittelpunkt, mit dessen Hilfe man sich beim Platzieren von Objekten orientieren kann.

Fang Linienverlängerung ein/ausschalten

Erlaubt es festzulegen, ob die Verlängerung der Objektlinien als Fanglinie verwendet werden können.

Gitter/Fang Einstellungen

Öffnet ein Dialogfenster, in dem Sie die Defaultwerte des Gitternetzes oder Fangpunkte ändern können. (Lesen Sie dazu mehr in diesem Kapitel im Abschnitt Das Panelfenster).

Das Menü Layout

Dieses Menü hilft bei der Anordnung der Grafikobjekte im Panel.

Abbildung: Menü Layout

Symbolbild Funktion
Objekt bewegen

Schaltfläche für Drehen mit der Maus. Sie können das Objekt um einen beliebigen Rotationswinkel drehen.

Sie können den Rotationswinkel auch im Eigenschaftenfenster Drehwinkel eingeben. Mit +90 Grad drehen Sie das Objekt gegen den Uhrzeigersinn. Mit -90 Grad drehen Sie das Objekt mit dem Uhrzeigersinn. Mit der Auswahl von 0 Grad wird das Objekt in die Ausgangslage zurückgesetzt. Nach dem Drehen zeigt das Feld den aktuellen Rotationswinkel des Objekts an.

Einrasten auf 45 Grad über die Shift-Taste ist möglich. Wenn Objekte rotiert werden, ergeben sich möglicherweise Rundungsfehler.

Hinweis:

Es können nur einfache Grafikobjekte (ausgenommen Rahmen) rotiert werden. Das Rotieren von komplexen Grafikobjekten ist nicht möglich.

Editiermodus. Bearbeiten von Punkten, Editieren von Konturen (Eckpunkte von Polygonen, Kurven).

Damit können Sie bei Polylinien und Freihandlinien (siehe Freihandlinie und Polygon) die (schwarzen) Kurveneditierpunkte sichtbar schalten. Durch Angreifen und Ziehen dieser Punkte können Sie die Form bzw. Kontur der Kurve gestalten. Um das Objekt wieder bewegen zu können, selektieren Sie den Move/Scale-Modus (die erste Option dieses Menüs).

Objekt in den Vordergrund oder Objekt in den Hintergrund (ordnet das Objekt ganz vorne an oder ordnet es ganz hinten an.)

Gruppe bilden

Ausgewählte Grafikobjekte und/oder Referenzen werden zu einer Gruppe zusammengefasst. Mit einem Klick auf ein Objekt, welches einer Gruppe angehört, wird die komplette Gruppe automatisch ausgewählt. Diese verhält sich wie ein einzelnes Objekt, d.h. Änderung der Größe oder Verschiebung wirkt sich auf die ganze Gruppe aus. Auf diese Weise können auch bestehende Gruppen zu einer Übergruppe beliebig oft zusammengefasst werden.

Ein Name kann für die Gruppe im Eigenschaftenfenster vergeben werden, über welchen Sie ansprechbar ist (mittels setValue()/getValue(), jedoch nicht über <Gruppenname>.<Grafikfunktionsname>()). Die Ansprechbarkeit der einzelnen Objekte und Untergruppen bleibt dabei bestehen (siehe Funktionen für alle Grafikobjekte (Übersicht)).

Grafikobjekte(-gruppen) können mit Referenzen(-gruppen) beliebig kombiniert werden.

Es können beliebig viele Bearbeitungsschritte an einer Gruppe rückgängig gemacht werden (Strg+Z), solange die Gruppe nicht aufgebrochen wird! Somit können auch keine Bearbeitungsschritte rückgängig gemacht werden, welche im aufgebrochenen Zustand durchgeführt wurden.

Gruppe aufbrechen

Bricht eine (Über-)Gruppe in ihre Objekte auf.

Ein oder mehrere ausgewählte Objekte horizontal oder vertikal spiegeln.

Es können alle WinCC OA Objekte gespiegelt werden, wobei ein Frame, alle Widgets, primitive Texte nur ihre Position verändern und der Text nach wie vor von links nach rechts gelesen werden kann.

Eine Spiegelung kann wieder rückgängig (Undo) oder wiederholt werden (Redo), dies muss jedoch für jedes Objekt einzeln durchgeführt werden (d.h. auch bei mehreren ausgewählten Objekten sind mehrere Schritte zurück/vor notwendig). Panel-Referenzen können ebenso gespiegelt werden. Dabei wird bei jedem Shape einer Referenz eine Überparametrierung (Transformation) angelegt. Auch hier können Undo-/Redo-Aktionen nur einzeln durchgeführt werden.

Füllmuster (Pixmaps) werden nicht automatisch mitgespiegelt.

Diese Aktionen ermöglichen es, ein oder mehrere Objekte horizontal oder vertikal zu spiegeln, wobei Referenzen lediglich um die Spiegelachse verschoben werden. D.h. im Gegensatz zu der einfachen Spiegelung von Objekten, werden Referenzen nicht "auf den Kopf gestellt", sondern werden auf die gegenüberliegende Seite der Spiegelachse mit dem gleichen Abstand zu dieser verschoben. Das Verschieben ist eine einzige Operation, d.h. die Referenz kann mit einem Undo Klick wieder an die alte Position verschoben werden. Wenn jedoch mehrere Objekte gespiegelt wurden, muss für jedes Objekt einzeln ein Undo Klick durchgeführt werden.
Zeichnet ein horizontales Layout um die selektierten Objekte bzw. das gesamte Panel.
Zeichnet ein vertikales Layout um die selektierten Objekte bzw. das gesamte Panel.
Fügt das selektierte Objekt zum ausgewählten Layout hinzu.
Entfernt das selektierte Objekt vom zugehörigen Layout.
Entfernt das ausgewählte Layout.

Objekte ausrichten

Objekte verteilen

Größen anpassen

Objekt links, rechts, vertikal oder horizontal zentriert ausrichten.

Objekte horizontal oder vertikal gleichmäßig teilen bzw. mit Abstand verteilen (Angabe vom Abstand in Pixel)

Die Größe von Objekten basierend auf dem als erstem ausgewählten Objekt ändern.

Tab order... (Tabulator Reihenfolge...) Öffnet das "Definiere Objekt Tabulator Reihenfolge"-Panel. (Siehe Abbildung unterhalb). Dieses zeigt alle Grafikobjekte des Panels für die Sie die Tabulatorreihenfolge definieren können.
Anmerkung:

Bei der Spiegelung eines Objektes werden Füllungen NICHT gespiegelt!

Abbildung: "Definiere Objekt Tabulator Reihenfolge"-Panel

So drehen Sie ein Grafikobjekt mit Rotationsmodus

  1. Markieren Sie das Grafikobjekt.
  2. Selektieren Sie die Option Rotationsmodus.
  3. Greifen Sie das Objekt an einem der Eckpunkte an, und ziehen Sie diesen mit der Maus in Kreisrichtung in die gewünschte Endlage. Ein Textfeld zeigt Ihnen dabei den aktuellen Rotationswinkel.
  4. Durch Loslassen fixieren Sie das Objekt in der neuen, gedrehten Lage.

Das Menü Objekte

Die Funktionen des Menüs Objekte ermöglichen das Erstellen der Grafikobjekte. Siehe auch Kapitel Einfache Grafikobjekte und Komplexe Grafikobjekte.

Abbildung: Menü Objekte

Anmerkung:

Die Menüeinträge entsprechen den Schaltflächen in der Symbolleiste Objektleiste und werden im Abschnitt Symbolleisten und im Kapitel Grafikobjekte erstellen detaillierter erklärt.

Welche Grafikobjekte zur Verfügung stehen, erfahren Sie in den Kapiteln Einfache Grafikobjekte und Komplexe Grafikobjekte.

Das Menü Format

Das Format-Menü erlaubt es die Grafikobjekte zu bearbeiten z.B. die Vordergrund-und Hintergrundfarbe zu setzen, den Linientyp zu definieren usw.

Abbildung: Das Format-Menü

Symbolbild Funktion
Vordergrundfarbe
Hintergrundfarbe
Vordergrundfarbe eines primitiven Textes.
Hintergrundfarbe eines primitiven Textes.

Linienstärke und

Linienart

Füllmuster

Schriftart, Schriftgröße,

Fett,

Kursiv. Setzt den Default-Font für alle neuen Objekte. Siehe Schriftart im Modul GEDI.

-

Gleiche Schriftart für alle Sprachen

Verwendet die eingestellte Schriftart für alle Sprachen.

Per Default ist diese Einstellung aktiv. D.h. wenn die Schriftart (siehe Option oben) auf Fett eingestellt ist und z.B. ein Rahmen gezeichnet wird, wird der Rahmentitel per Default für jede Projektsprache in der eingestellten Schriftart und Fett angezeigt.

Wenn z.B. die eingestellte Schriftart als Default-Schriftart weiterhin für alle Texte verwendet werden soll, aber z.B. nur der Rahmentitel in der Sprache Englisch in Kursiv dargestellt werden soll, muss die Sprache in der Online-Sprachumschaltung des GEDI auf Englisch eingestellt sein und anschließend die Schriftart über den Attribut-Editor des Rahmens auf Kursiv eingestellt werden.

Um z.B. die jetzt in Englisch eingestellte Schriftart (Kursiv) für den Rahmentitel auf die anderen Projektsprachen zu übertragen, kann die Kontextmenüoption "Für alle Sprachen Übernehmen" des "Schriftart" Attributes verwendet werden.

Wenn diese Option deaktiviert ist und z.B. ein Rahmen einem Panel hinzugefügt wird und zu diesem Zeitpunkt die Schriftart auf Kursiv gesetzt ist, dann wird diese Schriftart nur für die Sprache übernommen, die momentan in der GEDI Sprachumschaltung aktiv ist. Für alle anderen Sprachen wird der Rahmentitel in der Schriftart angezeigt, die in der Schriftart-Option (Format->Schriftart) für die bestimmte Sprache aus der GEDI Online-Sprachumschaltung zurzeit eingestellt ist.

Um für die Sprachen eines mehrsprachigen Projektes verschiedene Schriftarten zu verwenden, muss die Option deaktiviert werden

Hinweis:

Diese Option bewirkt kein Update der bereits vorhandenen Texte zu einer bestimmten Schriftart. D.h. wenn diese Option deaktiviert ist, während z.B. ein Rahmen einem Panel hinzugefügt wird, und danach erst aktiviert wird, wird die Schriftart des Rahmentitels in der aktuellen Sprache nicht auf die anderen Sprachen übertragen. Verwenden Sie dazu die oben beschriebene Kontextmenüoption im Attribut-Editor.

Text mit Rahmen
Linksbündig, zentriert, rechtsbündig
Gibt an, ob ein Polygon (Vieleck) geschlossen oder offen sein soll. Wenn Sie diese Option selektieren, ist das Polygon offen. Default ist geschlossen.

Die Default-Breite für ein Rohr.

Damit die Breite eines Rohres nicht für jedes gezeichnete Rohr separat eingestellt werden muss (Attribut "width" im Attribut-Editor), kann mittels dieser Option eine feste Breite in Pixel eingestellt werden. Diese wird dann auf alle neu gezeichneten Rohre angewendet - die Breite bereits gezeichneter Rohre wird nicht angepasst.

Schatten Öffnet das Panel zum Definieren der Schatteneinstellungen (Farbe, Versatz, Radius).
Kantenglättung anwenden Wenn Sie Kantenglättung aktivieren, wird Anti-Aliasing auf alle Objekte außer Frame, PrimitiveText und Rechteck (Rectangle) angewendet

Das Menü Fenster

Hier können Sie die offenen Panels schließen sowie die Anordnung der Panelfenster einrichten.

Abbildung: Fenster-Menü

Das Menü Tools

Abbildung: Tools-Menü

Das Tools-Menü bietet die folgenden Optionen:

  • Project Documentation: Diese Option öffnet das Projekt Dokumentation Menü.
  • High Speed Programming: Öffnet das High Speed Programming Menü
  • Node-RED: Öffnet den Node-RED Wizard.
  • CTRL Debugger: Startet den CTRL-Debugger.
  • DebugBreak() aktiv: Legt fest ob die Haltepunkte, welche mittels DebugBreak() gesetzt wurden aktiviert sind.
  • CTRL Script Leistungsanalyse: Öffnet die Leistungsanalyse für CTRL Scripts.
  • CTRL+Umschalt zeigt Panel Information: Aktiviert bzw. deaktiviert das UI_INFO Debug Flag, siehe Allgemeine Debug-Flags
  • Translator: Öffnet das Translator-Tool. Beachten Sie, dass diese Option nur bei einem mehrsprachigen Projekt vorhanden ist. Siehe Grundlagen zum Translator.
  • Start RunTime (<Projektname>): Startet das Startup-Panel (vision/startup.pnl), welches per Default das Loginpanel öffnet (kann im Panel-Skript des Startup-Panels angepasst werden). Diese Option ist äquivalent zu den Optionen "-p vision/startup.pnl -iconBar -menuBar" einer UI-Managers, jedoch ohne dass ein UI-Manager gestartet werden muss.
  • Setze aktives Icon Theme: Diese Option erlaubt es eine der vorhanden Icon Themes zur Laufzeit anzuwenden.
Anmerkung:

Icons, die zur Laufzeit geändert werden, werden nicht in bereits geöffneten Fenstern geändert. Erst wenn ein neues Modul geöffnet wird, wird das ausgewä Icon Theme dort angewendet.

Das Menü SystemMgm

Abbildung: SystemMgm

Dieses Menü dient zur Verwaltung des WinCC OA Systems. Nähere Informationen finden Sie unter System Management.

Das Menü Simple Symbols

Abbildung: Simple Symbols

Das Simple Symbols Menü bietet folgende Optionen:

  • Symbol <-> DPT Verknüpfung: Öffnet das Panel zur direkten Verknüpfung zwischen erstellten Symbolen und den entsprechenden Datenpunkttypen.

  • Drag'N'Draw: Mit diesem Panel können die innerhalb des Verknüpfungspanels festgelegten Symbole in ein Panel eingefügt werden.

Das Hilfemenü

Die Online-Hilfe für WinCC OA kann über das Hilfemenü geöffnet werden. Der erste Eintrag im Hilfemenü ruft die Startseite der Online Hilfe für WinCC OA auf. Die Referenz zum Grafischen Editor GEDI schlagen Sie unter Gedi Module nach.

Die Online-Hilfe für das Modul VISION unter Vision Module, und die Hilfe für das Modul PARA unter Para Module.

Unter Control-Programmierung... können Sie die Referenz für Control-Programmierung nachschlagen.

Über QT zeigt Information über das QT-Toolkit worauf die WinCC OA Benutzeroberfläche basiert.

Über WinCC OA zeigt Ihnen die ETM-Adress-Informationen und den aktuell installiert Stand von WinCC OA (Versionsnummer + Patch)

Abbildung: Das Hilfemenü