mobile ui

Discussion about recent product features & solutions!
Search

Post Reply
5 posts • Page 1 of 1
dongil
Posts: 48
Joined: Mon Oct 07, 2013 3:42 am

mobile ui

Post by dongil »

I am testing about mobile ui

my mobile ui web server version is wincc oa 3.14

and mobile app version is 3.18 patch 2 ( downloaded app from app market on my mobile phone - galaxy note 10 plus )

I showed the youtube this url ( https://www.youtube.com/watch?v=ysWTvGRoJqI )

I made all same. It was worked on chrome browser. but I got a error on mobile ui below.


Connection not possible, WCCILdata.

WCCOAui (201),2021.06.08.13:18:35.394, PARAM,WARNING, 224 Security issue:Username or Password entry found in config file!
WCCOAui (201),2021.06.08.13:18:35.646, SYS,INFO, 1,Manager Start, PROJ, CLI_IWT, V 3.18 - not initialized
WCCOAui (201),2021.06.08.13:18:35.904, SYS,INFO, 3,Trying to connect to (SYS:0 Data -num 0 CONN:1)@192.168.11.220:9777
WCCOAui (201),2021.06.08.13:18:35.919, SYS,INFO, 4,Connected to (SYS:0 Data -num 0 CONN:1)@192.168.11.220(192.168.11.220)
WCCOAui (201),2021.06.08.13:18:36.921, SYS,INFO, 0,Connection from 192.168.11.220 expired
WCCOAui (201),2021.06.08.13:18:36.938, IMPL,FATAL, 5,Connection not possible, WCCILdata

Do you have any idea to solve problem. ?

User avatar
leoknipp
Posts: 2645
Joined: Tue Aug 24, 2010 7:28 pm

Re: mobile ui

Post by leoknipp »

You can have a look at the log files at the server, maybe there are log messages written which help to find the cause.
Also you can try to start a Desktop-UI on a PC to check if a remote UI works.

When you are using a browser to show the UI the UI manager is started at the server and only graphical information is shown on the client (ULC UX client).

Best Regards
Leopold Knipp
Senior Support Specialist

dongil
Posts: 48
Joined: Mon Oct 07, 2013 3:42 am

Re: mobile ui

Post by dongil »

Remote UI ( ULX UX ) is working on the pc chrome browser.

only mobile version is not working.

Below is log on the web server when I tried to connect ( This log was showing in 2 or 3 second after error message was showing on the mobile phone.

WCCILdata (0), 2021.09.15 16:14:06.782, SYS, INFO, 4, Connected to (SYS: 191 Ui -num 202 CONN: 1) @ ::ffff:192.168.11.46 (::ffff:192.168.11.46)
WCCILdata (0), 2021.09.15 16:14:06.785, SYS, WARNING, 39, Connection lost, MAN: (SYS: 191 Ui -num 202 CONN: 1), Connection reset by peer (10054)

dongil
Posts: 48
Joined: Mon Oct 07, 2013 3:42 am

Re: mobile ui

Post by dongil »

I connected with server but I met another problem.

I added MultiPlexing Proxy on the project console and comment out #mxProxy = "none" on the config file.
Then mobile ui was connected.


It is showing login page on the mobile . but I want to show my screen instead of login page.
when I show it on PC. the url is http://192.168.11.40:6100/data/ulc/start.html then it is showing my page.


Below is mobile version log, I push the server on the mobile few second, then send the log to server.


WCCOAui (205), 2021.09.15 17:48:20.383, WinCC_OA, (1), 2021.09.15 17:41:30.619, Qt, QMetaObject::invokeMethod: No such method QListWidget::inputMethodQuery(Qt::InputMethodQuery,QVariant)
(1), 2021.09.15 17:46:33.850, Qt, QMetaObject::invokeMethod: No such method QListWidget::inputMethodQuery(Qt::InputMethodQuery,QVariant)
Error in communication with HTTP server: requested
http://192.168.11.40:6100/_info?sessionToken=x
HTTP code=404 Not Found

WCCOAui (0), 2021.09.15 17:48:20.215: PARAM/WARNING: using PVSS_II_ROOT /data/user/0/com.siemens.winccoaui/cache//pvssInst.conf
"WCCOAui [/data/user/0/com.siemens.winccoaui/cache/CLI_IWT_WEB_09082021/config/config]": pvss_path nonexistent, inaccessible or not a directory: C:/Siemens/Automation/WinCC_OA/3.14/
WCCOAui (205), 2021.09.15 17:48:20.216: WARNING: pvss_path "C:/Siemens/Automation/WinCC_OA/3.14/" in config file does not match with registered installation: "/data/user/0/com.siemens.winccoaui/cache/" !
WCCOAui (205), 2021.09.15 17:48:20.216: "3.14" does not match with manager version: "3.18" !!
WCCOAui (205), 2021.09.15 17:48:20.307: cannot set locale "en_US.iso88591"

User avatar
leoknipp
Posts: 2645
Joined: Tue Aug 24, 2010 7:28 pm

Re: mobile ui

Post by leoknipp »

The settings for MxProxy must fit on the server and client.
You can check if your are using a config and a config,webclient file and which settings you have made.

If you need further assistance you can possibly get in contact with your common WinCC OA support.

Best Regards
Leopold Knipp
Senior Support Specialist

Post Reply
5 posts • Page 1 of 1