Page 1 of 1

General internal archive error

Posted: Thu Oct 21, 2021 7:50 am
by funkey
Hello,

I use WCCOA V3.15 Patch 36 with a redundant server pair.
I have a few value archives, that make problems about two times a week.
This log entry appears after changing fileset when compressing C1 is done:

Code: Select all

WCCOAvalarch (4), 2021.10.21 04:08:22.410, IMPL, SEVERE,     54, Unexpected state, General internal archive error (ErrNum=11), Can't add set to element watch, [/work/WinCCOA/Exe/DataNew/ValueArchive/Archive.cpp:7030]
When this is appearing, then the last archive file is switched to offline and I have no charting for the period of this file.
Is there a possibility to find out what is going wrong with my archives?

Edit: Forgot to mention, that all works perfect again after restart of the two server projects.....

Best regards
Christoph

Re: General internal archive error

Posted: Fri Oct 22, 2021 8:03 pm
by leoknipp
It looks like a similar problem appeared some years ago in 3.16 and was fixed there.
If you need further assistance please get in contact with your common WinCC OA support.

Please take into account that WinCC OA is no longer part of the mainline support since May 2021.

Best Regards
Leopold Knipp
Senior Support Specialist

Re: General internal archive error

Posted: Sat Oct 23, 2021 8:22 am
by funkey
Hi,

thanks. I know that mainline support for this version is over. We have planed an update to V3.18 on August next year.
Updating from Patch 10 to Patch 36 made things much better, so patches try to handle this bug.
Before we had an every day 3 archives problem, now we have a one archive every 3 days problem.