Animations in Layouts

Discussions about product bugs & problems!
Note: This is no replacement for the Official ETM Support!
Search

Post Reply
4 posts • Page 1 of 1
GerrieF
Posts: 8
Joined: Tue Sep 29, 2020 1:57 am

Animations in Layouts

Post by GerrieF »

Hi all,

I am having an issue where my animations act strangely when placed in a layout.
If my panel components are not in a layout they work fine, but as soon as the components are placed in a layout it dies some strange things...

How can I get my animations to work as expected even with the panel placed in a layout?

Animations in a layout:
Image

Animations NOT in a layout:
Image

User avatar
leoknipp
Posts: 2612
Joined: Tue Aug 24, 2010 7:28 pm

Re: Animations in Layouts

Post by leoknipp »

From the pictures we cannot see how you have implemented the animations.
Are you using animated graphics or are you changing properties of WinCC OA objects?

If you are changing properties possibly the difference is caused by the UI because it recalculates the layout if changes are applied to objects.

Best Regards
Leopold Knipp
Senior Support Specialist

GerrieF
Posts: 8
Joined: Tue Sep 29, 2020 1:57 am

Re: Animations in Layouts

Post by GerrieF »

Hi Leopold,

Thanks for your reply.
This is my animate code:
int g;
g = createAnimation();
animate(g, "icon_bannerType", "sizeAsDyn", icon_bannerType.sizeAsDyn, icon_bannerType.sizeAsDyn, makeMapping("keyValues", makeMapping(0.5, makeDynInt(40, 40)),"easingCurve", "OutExpo", "duration", 1000, "loopCount", 1));
startAnimation(g, "keep", makeMapping("loopCount",animationLoops));

So, are you saying I cannot animate a component in a layout?

User avatar
leoknipp
Posts: 2612
Joined: Tue Aug 24, 2010 7:28 pm

Re: Animations in Layouts

Post by leoknipp »

I have tested in 3.18 with the same animation as in your code and I could not see a similar problem.
During one of the tests I got the following log message:
WCCOAui (1), 2021.07.19 13:26:35.605, CTRL, WARNING, 62/uim, Das Attribut '' konnte nicht gesetzt werden. Ort:
Module: _QuickTest_
Panel: C:\WinCC_OA\projects\etm\test_318\panels\animation.pnl [animation.pnl]
Object: 0 named: "RECTANGLE1" of type: RECTANGLE
, managed by layout

It looks like there are some limitations when using layouts and trying to change the size of objects.

If you need further assistance please get in contact with your common WinCC OA support and add a simple example to your support inquiry.

Best Regards
Leopold Knipp
Senior Support Specialist

Post Reply
4 posts • Page 1 of 1