Alert not in datasets

Discussions about product bugs & problems!
Note: This is no replacement for the Official ETM Support!
Search

Post Reply
4 posts • Page 1 of 1
User avatar
tmalone
Posts: 134
Joined: Mon Nov 22, 2010 11:21 pm

Alert not in datasets

Post by tmalone »

I get multiple errors about alarm archiving:

WCCILdata (0), 2021.04.18 09:57:03.807, IMPL, SEVERE, 54, Unexpected state, AlertHistory, commitUpdate, Alert not in datasets nor in living DB
System1:_BackupMedium.FreeKB:_alert_hdl.3._state (Type: 9 Sys: 1 Dp: 89 El: 8 : _alert_hdl.3._state)

I tried to put -repair alerts on the data manager but that did not solve this issue.

I tried to force the archive to switch to new file and remove old history files.

These alarms are making the system go into Emergency Mode. I can't seem to fix this one.

User avatar
kilianvp
Posts: 285
Joined: Fri Jan 16, 2015 10:29 am

Re: Alert not in datasets

Post by kilianvp »

you can try:
[data]
checkDiskSpace = 0
or
[data]
DP_DiskCheck = ""
this should stop the Emergency Mode.

User avatar
tmalone
Posts: 134
Joined: Mon Nov 22, 2010 11:21 pm

Re: Alert not in datasets

Post by tmalone »

While that will avoid the emergency, I would rather leave that feature as designed.

Is there any way to correct the root cause, the missing archive records?

Todd

User avatar
leoknipp
Posts: 2505
Joined: Tue Aug 24, 2010 7:28 pm

Re: Alert not in datasets

Post by leoknipp »

The option "-repair alerts" can only be used to solve the inconsistency in the database which is reported with the log message "no gone alert between two came ones" during started.
A wrong configuration of the _alert_hdl config or the cause of the log message will not switch the system to emergency mode.
The emergency mode is only entered if the system is low on disk space and/or memory.

Did you try to deactivate/activate the _alert_hdl config?
What is the time stamp of the _original value for this DP element?

Best Regards
Leopold Knipp
Senior Support Specialist

Post Reply
4 posts • Page 1 of 1