3.16P17 - Silent print of PDF ewo

Discussions about product bugs & problems!
Note: This is no replacement for the Official ETM Support!
Search

Post Reply
5 posts • Page 1 of 1
hbraun
Posts: 11
Joined: Wed Aug 09, 2017 5:25 am

3.16P17 - Silent print of PDF ewo

Post by hbraun » Mon Mar 23, 2020 3:24 pm

Hello everyone,

I try to print a panel which includes a PDF-ewo with silent print function but the in the printout the PDF-ewo is always blank (PDF file seems to be loaded by the EWO though, "load" returns 0).

I tried adding a delay after loading the PDF but the EWO remains blank in the output.

Is there anything special to consider when using the PDF-ewo with silent print? Or is it not possible at all?

Kind regards,

HBRaun

Vakhnovwtskiy
Posts: 2
Joined: Mon Feb 10, 2020 2:35 pm

Re: 3.16P17 - Silent print of PDF ewo

Post by Vakhnovwtskiy » Thu Mar 26, 2020 1:20 pm

Hello
I tried to use PDF-ewo too. I want to open PDF file on a panel.
My code in "Initialize" of Pdf_ewo1.
main()
{
this.load("C:/2.pdf");
}

When the Panel is run PDF_ewo is empty. And the Log is empty too.

I used 3.16P015 and 3.17P002

How open PDF documents on a panel?

User avatar
leoknipp
Posts: 2206
Joined: Tue Aug 24, 2010 5:28 pm

Re: 3.16P17 - Silent print of PDF ewo

Post by leoknipp » Fri Mar 27, 2020 7:55 am

When using silentPrint it is possibly a timing issue.
If you are using silentPrint the panel is printed when the "Initialize" scripts are executed. Maybe the EWO has not loaded the pdf at this time and therefore you do not see it at the print of the panel.
When opening the panel in a Vision module can you see a delay in displaying the loaded pdf file?

Best Regards
Leopold Knipp
Senior Support Specialist

Vakhnovwtskiy
Posts: 2
Joined: Mon Feb 10, 2020 2:35 pm

Re: 3.16P17 - Silent print of PDF ewo

Post by Vakhnovwtskiy » Fri Mar 27, 2020 10:04 am

When I'm openning the panel with EWO PDF in a Vision module I'm seeing only gray window. There was not delay.
Do EWO use any other components from Windows which I needed to install?

hbraun
Posts: 11
Joined: Wed Aug 09, 2017 5:25 am

Re: 3.16P17 - Silent print of PDF ewo

Post by hbraun » Fri Mar 27, 2020 1:46 pm

Hello Mr. Knipp,

I tested it also with a delay (up to 30 seconds) after loading the PDF, but the content of the PDF does still not appear on the printout.

When I open the panel in quick test there is no noticable delay until the PDF is displayed. Also printing the panel including PDF-EWO with "printPanel()" function works in quick test.

Note : In the printout created with silent print the PDF-EWO seems to load the PDF: I can see the correct page numbers and scrollbars in the printout.
Just the content of the PDF is not displayed, only blank white pages.

So it seems the problem is related to the silent mode of the UI.

Kind regards,

HBraun

Post Reply
5 posts • Page 1 of 1