SVN in Gedi

Discussions about product bugs & problems!
Note: This is no replacement for the Official ETM Support!
Search

Post Reply
3 posts • Page 1 of 1
NOertel
Posts: 4
Joined: Fri Jul 26, 2019 10:46 am

SVN in Gedi

Post by NOertel » Wed Sep 11, 2019 3:05 pm

Hello,

I'm installed SVN 1.12 on the Client and the Windows Explorer show via the marked Icons that my project is committed.
Furthermore I modify the Config at the installation path from WinCC. And the LogViewer does start the SVN.ctl

Code: Select all

WCCOAui      (1), 2019.09.11 16:56:39.886, CTRL, WARNING,     5/ctrl, Ort der folgenden Meldung: 
    Module: Gedi_1
    Script: gedi/SVN.ctl
    Library: C:\Siemens\Automation\WinCC_OA\3.16\scripts\libs\svnlib.ctl
    Line: 110
WCCOAui      (1), 2019.09.11 16:56:39.886, IMPL, WARNING,    61, Cannot open file, CtrlCB, readFromFile, C:/Users/Nico WinCC OA Server/AppData/Local/Temp/WCCOAui.oa4200 : No such file or directory
WCCOAui1:["SVN_isInstalled() FALSE"]
WCCOAui1:["SVN_isInstalled() "]
WCCOAui1:["SVN:  no command line installed or project not in repository.  Use -dbg SVN for more information"]
These are the details from the LogViewer. I also started the Gedi with -dbg SVN.

Best NOertel

NOertel
Posts: 4
Joined: Fri Jul 26, 2019 10:46 am

Re: SVN in Gedi

Post by NOertel » Thu Sep 12, 2019 9:43 am

I tried something with the debugger and found the failure at the tmpnam() or at SVN_cmdline(). The used shell have no rights to create a file at the temp folder, so it can`t read the information from it. Its possible to write a hard path into the svnlib.ctl. Do you probably know which user will used to call system() ?

gschijndel
Posts: 86
Joined: Tue Jan 15, 2019 2:12 pm

Re: SVN in Gedi

Post by gschijndel » Fri Sep 13, 2019 7:07 am

I think the problem is that the path for the temp file contains whitespace.

Post Reply
3 posts • Page 1 of 1